Delphi вики
Advertisement

Активная ячейка

ActiveCell - активная ячейка
Range("A1") - Диапазон, содержащий ячейку А1
Cells(1, 1) - Первая ячейка в диапазоне

Если выбрана ячейка А1, то все предыдущие значения равны

Свойства

Содержимое ячейки
Value Значение ячейки диапазона. Это свойство является свойством Range по умолчанию, т.е. записи

Range("A1") = 1, и Range("A1").Value = 1
одинаковы

Formula Формулу в формате A1. Например, следующая инструкция вводит в ячейку формулу =$А$4+$А$10:

Range("A1").Formula = "=$А$4+$А$10"

FormulaLocal Не англоязычные (местные) формулы в формате А1. Например, следующая инструкция вводит в ячейку формулу =СУММ(С1:С4):

Range("A1").FormulaLocal = "=СУММ (С1:С4) "

FormulaR1C1 Формулу в формате R1C1. Например, формула КОРЕНЬ($B$3):

Range("A1").FormulaR1C1= "=SQRT(R3C2)"

FormulaR1C1Local Не англоязычные (местные) формулы в формате R1C1. Например, формула КОРЕНЬ($B$3):

Range("A1").FormulaR1C1= "=КОРЕНЬ(R3C2)"

Text Свойство доступно только для чтения. Возвращает содержание диапазона в текстовом формате/

Полезные функции

Количество строк:

Cells(Rows.Count,1).End(xlUp).Row
Advertisement